Bulwark Core 2.1.1.0 Mandatory Update

core

#1

Bulwark Core 2.1.1.0 Mandatory Update

Bulwark 2.1.1.0 is a mandatory update to address a potential future issue with new staking requirements once the staking requirements spork is activated. The spork is not active at this time, will be at a later date after amble time has been given to update, this is a preventative measure.


How to Update

As always, it is recommended to backup the existing wallet.dat file to a safe location before upgrading if you haven’t done so already via File -> Backup wallet and saving it in a different directory with a new name. If you use CLI/Linux, you can backup using the command ./bulwark-cli backupwallet. If your wallet is not running currently, you can back up the file “wallet.dat” from e.g. Start -> Run -> %APPDATA%\Bulwark on Windows by making a copy elsewhere.

  1. Gracefully exit/stop the current wallet from the wallet. (File - Exit or ./bulwark-cli stop)

  2. Download and install the new wallet appropriate for your OS.
    Linux/Rpi: Overwrite the existing executable files with the newly downloaded wallet binaries.
    Windows: Install via the setup executable file and run through the setup wizard to install.
    Mac OSX: Download .dmg file, open .dmg then drag bulwark icon to the applications folder icon. (copy over /Applications/bulwark-Qt)

  3. Re-start the wallet. (Launch from your Bulwark shortcut icon or ./bulwarkd for linux)

  4. Once the wallet finishes syncing


Changelog:

Technical

  • Update to stake consensus requirements

Miscellaneous

  • Remove extra debug log entry
  • Update to v2.1.1.0
  • Minor format change

Download:


made this a banner . It will appear at the top of every page until it is dismissed by the user. #2

removed this banner . It will no longer appear at the top of every page. #3